Функция СобратьМассивВСтроку(МассивСтрок, Разделитель = ";") Экспорт
 МассивСтрок= Новый Массив;
 кол=МассивСтрок.Количество();
 ОбщааяСтрока="";
 Для Инд=0 по кол Цикл 
 ОбщааяСтрока=ОбщааяСтрока+Разделитель+МассивСтрок.Получить(Инд);
 КонецЦикла;
 Возврат(ОбщааяСтрока);
КонецФункции

 

 

Функция РазложитьСтрокуВМассивПодстрок(Знач Стр, Разделитель = ";") Экспорт    
 Если Разделитель = " " Тогда
 Стр = СокрЛП(Стр);
 Пока 1=1 Цикл
 Поз = Найти(Стр,Разделитель);
 Если Поз=0 Тогда
 МассивСтрок.Добавить(Стр);
 Возврат МассивСтрок;
 КонецЕсли;
 МассивСтрок.Добавить(Лев(Стр,Поз-1));
 Стр = СокрЛ(Сред(Стр,Поз));
 КонецЦикла;
 Иначе
 ДлинаРазделителя = СтрДлина(Разделитель);
 Пока 1=1 Цикл
 Поз = Найти(Стр,Разделитель);
 Если Поз=0 Тогда
 МассивСтрок.Добавить(Стр);
 Возврат МассивСтрок;
 КонецЕсли;
 МассивСтрок.Добавить(Лев(Стр,Поз-1));
 Стр = Сред(Стр,Поз+ДлинаРазделителя);
 КонецЦикла;
 КонецЕсли;   
КонецФункции