WshShell = Новый COMОбъект("WScript.Shell");
ТекКаталогРаботыПользователя = WshShell.CurrentDirectory;

 

 

Функция ПолучитьПредставлениеИнформационнойБазы() Экспорт
 Если ПустаяСтрока(СтрокаСоединенияИнформационнойБазы) Тогда
 СтрокаСоединенияИнформационнойБазы =  СтрокаСоединенияИнформационнойБазы();
 КонецЕсли;
 ЭтоФайловаяИБ = Найти(Врег(СтрокаСоединенияИнформационнойБазы), "FILE=") = 1;
 Если ЭтоФайловаяИБ Тогда
 ПутьКБД = Сред(СтрокаСоединенияСБД, 6, СтрДлина(СтрокаСоединенияСБД) - 6);
 ФайловаяБД = Истина;
 Иначе
 // надо к имени сервера прибавить имя пути информационной базы
 ПозицияПоиска = Найти(Врег(СтрокаСоединенияСБД), "SRVR=");
 
 Если ПозицияПоиска <> 1 Тогда
 Возврат Неопределено;
 КонецЕсли;
 
 ПозицияТочкиСЗапятой = Найти(СтрокаСоединенияСБД, ";");
 НачальнаяПозицияКопирования = 6 + 1;
 КонечнаяПозицияКопирования = ПозицияТочкиСЗапятой - 2; 
 
 ИмяСервера = Сред(СтрокаСоединенияСБД, НачальнаяПозицияКопирования, КонечнаяПозицияКопирования - НачальнаяПозицияКопирования + 1);
 
 СтрокаСоединенияСБД = Сред(СтрокаСоединенияСБД, ПозицияТочкиСЗапятой + 1);
 
 // позиция имени сервера
 ПозицияПоиска = Найти(Врег(СтрокаСоединенияСБД), "REF=");
 
 Если ПозицияПоиска <> 1 Тогда
 Возврат Неопределено;
 КонецЕсли;
 
 НачальнаяПозицияКопирования = 6;
 ПозицияТочкиСЗапятой = Найти(СтрокаСоединенияСБД, ";");
 КонечнаяПозицияКопирования = ПозицияТочкиСЗапятой - 2; 
 
 ИмяИБНаСервере = Сред(СтрокаСоединенияСБД, НачальнаяПозицияКопирования, КонечнаяПозицияКопирования - НачальнаяПозицияКопирования + 1);
 
 ПутьКБД = ИмяСервера + "/ " + ИмяИБНаСервере;
 ФайловаяБД = Ложь;
 КонецЕсли;
 Возврат ПутьКБД;
КонецФункции