Вычисление хеша файла.

двФайл = Новый ДвоичныеДанные(ИмяФайла);        
 Строка = Base64Строка(двФайл);
 НачПозиция = 1;
 hash=5831;
 M=33;
 ДлинаСтроки = СтрДлина(Строка); 
 Пока НачПозиция <= ДлинаСтроки Цикл 
 СтрокаБлока = Сред(Строка, НачПозиция, 10); 
 Для к = 1 По СтрДлина(СтрокаБлока) Цикл 
 hash = M * hash + КодСимвола(СтрокаБлока, к) 
 КонецЦикла; 
 hash = hash % 18446744073709551616; 
 НачПозиция = НачПозиция + 10 
 КонецЦикла; 
 Результат = ""; 
 Пока hash > 0 Цикл 
 Остат = hash % 16; 
 hash = (hash - Остат) / 16; 
 Результат = Сред("0123456789ABCDEF", Остат + 1, 1) + Результат 
 КонецЦикла;