VitalInvent.com

// Преобразовывает таблицу значений в массив структур
 &НаСервере Функция ПреобразоватьТаблицуВМассив(ТаблицаЗначений) Экспорт Перем РезультатМассив; Перем СтруктураСтрока; // Сформируем массив структур

Функция ЗапросSQL (SQLServer,Login,Password,ТекстSQL)   //Функция выборки данных из SQL сервера и передача во временную таблицу 1С

СтрокаСоединения = ("Provider=SQLOLEDB;Driver={SQL Server}; Deleted=No; Data Source = ") + SQLServer +
(";UID=") + Login + ("; PWD=") + Password + (";");

1С 7.7

1cv7.exe MODE [ /M | /D | /U | /N | /P ],

где MODE - режим запуска, может принимать только одно из трех значений :
config - режим конфигуратора;
debug - режим отладчика;
enterprise - нормальный (рабочий) режим.
monitor - режим "Монитор".

WshShell = Новый COMОбъект("WScript.Shell");
ТекКаталогРаботыПользователя = WshShell.CurrentDirectory;

 


Программные продукты Фирмы «1С» в большинстве случаев защищены от копирования с помощью аппаратных LPT или USB ключей защиты типа HASP от фирмы Aladdin. Система лицензирования программ линейки 1С:Предприятие 8.* дает пользователям более гибкие возможности масштабирования при увеличении количества пользователей, наращивании вычислительных мощностей информационных систем, росте компании и т.д., но при этом у клиента может оказаться сразу несколько ключей от различных лицензий и версий программ 1С, внешне очень похожих, что может вызвать определенные затруднения.

Причем, довольно часто, в интернете встречается неполная и взаимопротиворечащая информация.

Данная статья должна помочь окончательно расставить точки над «i» и помочь при идентификации ключей от программных продуктов «1С».

Как добавить запись в непериодический независимый регистр сведений?

НаборЗаписей = РегистрыСведений.ЗначенияСвойств.СоздатьНаборЗаписей();

 НаборЗаписей.Отбор.Номенклатура.Установить(ТекущаяНоменклатура); 
 НаборЗаписей.Отбор.Свойство.Установить(ТекущееСвойство); 

 НоваяЗапись = НаборЗаписей.Добавить(); 
 НоваяЗапись. Номенклатура = ТекущаяНоменклатура; 
 НоваяЗапись.Свойство = ТекущееСвойство; 
 НоваяЗапись.Значение = ТекущееЗначение;
НаборЗаписей.Записать();

// Работа 1C с FTP (8.0,8.1,8.2)

// Загрузка файлов на FTP сервер
Процедура ЗагрузитьОтмеченные(Кнопка)
Сервер = Новый FTPСоединение(FTPServer);
Для Каждого Файл Из ПолеСписка Цикл
Если Файл.Пометка Тогда
Сервер.Получить(Файл.Значение.ПолноеИмя, "с:\temp" + Файл.Значение.ПолноеИмя);
Файл.Пометка = Ложь;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Функция СобратьМассивВСтроку(МассивСтрок, Разделитель = ";") Экспорт
 МассивСтрок= Новый Массив;
 кол=МассивСтрок.Количество();
 ОбщааяСтрока="";
 Для Инд=0 по кол Цикл 
 ОбщааяСтрока=ОбщааяСтрока+Разделитель+МассивСтрок.Получить(Инд);
 КонецЦикла;
 Возврат(ОбщааяСтрока);
КонецФункции

 

Множество примеров работы с почтой и в конце теоретические основы.

Почта = Новый Почта;
Почта.Подключиться();
Письмо = Новый ПочтовоеСообщение;
Письмо.Получатели.Добавить("хххх@хххх.хх");
Письмо.Тема = "Автоматическое";
Письмо.Текст = "АААА";
Письмо.Вложения.Добавить("C:\test1.txt");
Почта.Послать(Письмо);
Почта.Отключиться();

В данном случае выполняется стандартная для всех версий Windows команда ping на IP-адрес, ответа от которого не будет и выставляется время ожидания отклика в секундах.
В данном примере задержка составляет 5 секунд.

 

Вычисление хеша файла.