Подробнее...Мультибазовый отчет СКД - гибкая система получения данных с физически разных но одинаковых по запрашиваемым данным баз. Например из баз в разных филиалах при наличии доступа к сам базам или из Бухгалтерии, УТ и ЗИК одновременно. Сбор и отображение отчетности из разных баз и возможно даже конфигураций с одинаковыми частями учета.

Этот отчет предназначен для программистов. Он наглядно может представить принцип создания отчета СКД по COM соединению, и созданию запросов на стороне сервера. По сути это шаблон СКД отчета, основанного на COM соединении на стороне сервера, может служить для программистов основой для создания своего отчета из нескольких баз. В отчете есть возможность задавать как отдельные данные для каждой базы, так и задавать на форме общие параметры, такие как дата  или период. В этом шаблоне проверены схемы работы в режиме мультиотчета, поэтому шаблон предлагает один иV82.COMConnector, COMОбъект,  Automation - сервер.

 

Функция добавления

{codecitation class="brush: vb; gutter: true;" width="500px" }

Функция ДобавитьНули(Значение, НужнаяДлинаЗначения)

Значение = СтрЗаменить(Формат(Значение, "ЧГ="), " ", "");
НадоНулей = НужнаяДлинаЗначения - СтрДлина(Значение);
ВедущиеНули = Формат(0,"ЧЦ="+НадоНулей+";ЧН=; ЧВН=; ЧГ=0");
Возврат ВедущиеНули + Значение;

КонецФункции

{/codecitation}

 

Передача файла на сервер 1с.

{codecitation class="brush: vb; gutter: true;" width="500px" }

&НаКлиенте

Функция ПередатьФайлНаСервер(Путь)
Файл = Новый Файл(Путь);
ФайлИсточник = Файл.ПолноеИмя;
Адрес = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ФайлИсточник));
Возврат(Адрес);
КонецФункции // ПередатьНаСервер()
{/codecitation}

 

Чтение DBF

{codecitation class="brush: vb; gutter: true;" width="500px" }

ФайлВВР = Новый XBase;
ФайлВВР.ОткрытьФайл("с:\staff.dbf",Истина); //только для чтения
ФайлВВР.Первая();
ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить(...);
//создание колонок
Пока НЕ ФайлВВР.ВКонце() Цикл
Нов = ТЗ.Добавить();
Нов.Наименование = ФайлВВР.Name;
//заполнение полей
ФайлВВР.Следующая();
КонецЦикла,
ФайлВВР.ЗакрытьФайл();

{/codecitation}

 

 

пример коммандного файла, формирующего переменные для года, месяца, дня недели и пр.:

Подробнее...Клиент-серверная версия Рисунок трехступенчатой ​​структуры (так называемые "trehzvenka»), которая включает в себя: клиент, сервер и сервер базы данных 1С. Это совершенно отдельный компонент, которые могут быть объединены для достижения наилучших результатов в любых допустимых комбинации. Рассмотрим следующую схему:

Давайте начнем с клиентом является текущей версией платформы (8,2), использование трех типов клиентов. Давайте рассмотрим их подробнее.

Жир клиента. Это классический 1С клиента, выше на 8,2 платформа была единственным доступным видом клиента. Схема толстого клиента выглядит следующим образом: клиентское приложение запрашивает данные с сервера 1С свою очередь, называет их из базы данных, и сделать его обратно к клиенту, где они обрабатываются и производится.

Как вы можете видеть, эта схема не является оптимальной: сервер 1С сути, это просто слой между клиентом и базой данных, все расчеты на клиенте. Это предъявляет высокие требования к клиентскому ПК, такие как вычислительная мощность сервера не используется. Это должно быть ясно, что в режиме толстого клиента, вы не получите увеличение bystrodeystiviya от перехода к клиент-серверной версии, возможно, даже наоборот.

'Перед работой необходимо импортировать пространство имен System.IO:

Imports System.IO'

Как создать новый файл?

В сети сейчас большое количество файлообменников. Все они различаются при детальном рассмотрении. Для обычного незарегистрированного пользователя внешне все выглядит достаточно просто. Разработчики файлообменников создают простой интерфейс, чаще сводящийся к выбору файла на главной странице и закачке его на файлообменник. Но при регистрации вы получаете определенные преимущества и эти преимущества тоже различаются. В сети много статей про заработок на файлообменниках, но в данной статье будут рассматриваться только количественно качественные характеристики файлообменников.

Это полный список наиболее крупных файлообменников сети. Список правится и дополняется.